Google Cloud SQL - Intermittent reporting errors

Incident Report for EasyMetrics

Resolved

This incident has been resolved.
Posted May 05, 2025 - 19:56 EDT

Update

We are continuing to monitor for any further issues.
Posted May 05, 2025 - 18:55 EDT

Monitoring

The issue affecting our legacy reports which lead to intermittent errors has been resolved, we will continue to closely monitor the the associated infrastructure for any further issues.
Posted May 05, 2025 - 17:54 EDT

Identified

Easy Metrics is aware that our customers are currently experiencing degraded performance when accessing legacy reports.

Clients may experience inconsistent report execution which may include:
Excessive waiting time (>5 minutes)
Report Inavailability

Clients may be presented with an error message such as:
"Calculations are in progress. Please allow up to 5 minutes before running reports"
"Failed to run report"
"There was an error on the server. Try again or contact site administrators."

We're working closely with our partners at Google to resolve the intermittent access issues to our Legacy Reporting.
Posted May 05, 2025 - 15:55 EDT

Investigating

Easy Metrics is aware that our customers are currently experiencing degraded performance when accessing legacy reports & is investigating the issue
Posted May 05, 2025 - 15:53 EDT
This incident affected: EasyMetrics (Insights - Legacy) and Google Cloud Platform Google Cloud SQL.