JobTrak - Increased error rates with backend services

Incident Report for EasyMetrics

Resolved

This incident has been resolved.
Posted Aug 01, 2025 - 16:16 EDT

Monitoring

The root cause preventing a limited number of JobTrak services to scale with additional traffic has been identified and resolved.

All JobTrak services have been returned to an operational state & we will continue to monitor them over the next few hours.
Posted Aug 01, 2025 - 10:51 EDT

Investigating

We’re currently investigating reports of a potential service interruption with Jobtrak Services, our team is currently investigating.

We apologize for any inconvenience and will post another update as soon as more information becomes available.
Posted Aug 01, 2025 - 09:58 EDT
This incident affected: JobTrak (Projects Service, Department Service, Employees Service, Facilities Service, Teams Service).