Amazon Web Services Outage

Incident Report for EasyMetrics

Resolved

Recovery of all AWS services is now complete & we have continued to monitor the data ingress pipelines for the last few hours to verify the stability associated AWS services.

Our team will continue to monitor all data ingress pipelines closely throughout the evening & will follow up with a post mortem when more specific information becomes available in the AWS post-event summary.
Posted Oct 20, 2025 - 20:59 EDT

Monitoring

All backlogged Lambda invocations and queued events have been processed by our data ingress systems

The EasyMetrics team is working through validating an operational status on our dependent systems and will continue to monitor the mitigations by AWS over the next few hours.
Posted Oct 20, 2025 - 17:26 EDT

Investigating

Easy Metrics is aware that our tier-1 Cloud Service Provider, Amazon Web Services, is experiencing major systemic issues. These issues are causing failures across multiple AWS services, which has now begun to impact a portion of our data ingestion pipelines for subscribers transferring data with AWS.

Our team is monitoring the incident closely and will provide further updates as more information becomes available from AWS.

We understand the importance of our services to your operations and apologize for any disruption this may cause. Our team is committed to keeping you informed and restoring full functionality as quickly as possible.

Thank you for your patience and understanding.
Posted Oct 20, 2025 - 15:17 EDT
This incident affected: Ingress (Workflow Orchestrator - Core).